Author Topic: How to avoid transformation of input coordinates into principal axis system?  (Read 7041 times)

ComingNine

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
 :)
Hi everybody,

When doing constrained optimization, using redundant internal coordinates, there is such message in job.* files:
Code: [Select]
    this is R E L A X ...
    ...
    Updated coordinates will be transformed into principal axis system
    ...

And the coordinates are transformed.

Because I need to keep coordinates in the input coordinate frame, I am wondering how to avoid such transformation of coordinates?

Thank you very much!

uwe

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 405
  • Karma: +0/-0
Hi,

generally using statpt instead of relax should help since statpt does not by defalt move the coordinates to principal axes system.

statpt is used by default since Turbomole version 6.0. Only if you use the tmole script relax is still used.

The bigger problem are the constraints. If you fix an internal coordinate and then generate internal redundant coordinates, define will re-calculate the cartesian coordinates (and move the origin to the center of mass). Especially if you run scan jobs where the value of the fixed internal coordinate does not match the value of the current coordinates, this is not avoidable - since here the goal actually is to change the coordinates.

A work around would be:

  • make a usual input without internal coordinates or constraints
  • copy the coordinates to a new file or directory
  • fix internal coordinates and let define determine the set of internal redundant coordinates
  • replace the coordinates (and just the $coord section, not the $internal redundant, etc. keyword in the coord file) with the previously saved ones
  • then run jobex as usual (for older Turbomole versions: with option -statpt)


The 'trick' is that during the calculation only the cartesian coordinates and the definition of the internal coordinates are needed - the values of the internal coordinates are re-calculated but not read from file.

Hope it helps,

Uwe

ComingNine

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Dear Uwe,
 
  Your suggestions are very inspiring. I will try to test the procedure. Thank you very much for your help!

Best wishes,