Author Topic: GA Parallel run error in ridft_mpi  (Read 2632 times)

ygchen

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
GA Parallel run error in ridft_mpi
« on: October 13, 2014, 11:11:54 am »
System: CentOS 6.3, kernel 2.6.32-220.el6.x86_64
GLIBC: 2.12
Turbomole: v6.6 DEMO
I'm trying to run a geo-opt task with 120 atoms (to fit the demo limitation) at DFT level. It works fine for both single thread (ridft & rdgrad) and multi-threaded SMP (ridft_smp & rdgrad_smp, set TM_PAR_FORK=on), but failed for GA/SMP (ridft_mpi & rdgrad_mpi, unset TM_PAR_FORK).
When GA/SMP failed, I find the file job.1 shows:
Code: [Select]
data group $actual step is not empty
 due to the abend of ridft

I notice that the IBM Platform MPI 9.1 which is shipped by turbomole does NOT support CentOS 6.x (as for CenOS series, only CentOS 5.x and GLIBC up to 2.11 are supported), I'm not sure whether this problem is caused by the version of GLIBC or by the distribution of Linux ?
« Last Edit: October 13, 2014, 11:20:19 am by ygchen »

uwe

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 410
  • Karma: +0/-0
Re: GA Parallel run error in ridft_mpi
« Reply #1 on: October 13, 2014, 03:04:46 pm »
Hello,

please just run a single-point energy calculation (ridft in your case) and send the output files (master and slave*) to the Turbomole support.

The kernel is probably not a problem, but the minimum version of the glibc can be. Check if the requirements of ridft:

strings $TURBODIR/bin/`sysname -s`_ga/ridft_mpi | grep GLIBC

are fulfilled by your local glibc version:

strings /lib/libc.so.6 | grep GLIBC

Regards,

Uwe

ygchen

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: GA Parallel run error in ridft_mpi
« Reply #2 on: October 14, 2014, 10:28:58 am »
Thanks for reply. I replace my OS from CentOS 6.3 to RHEL 6, all problems are gone. It's really weird. Anyway, it works.