Author Topic: COSMO isodensity cavity  (Read 2898 times)

saleheen_noman

  • Jr. Member
  • **
  • Posts: 10
  • Karma: +0/-0
COSMO isodensity cavity
« on: November 05, 2015, 04:40:47 am »
Hi

I was trying to run a cosmo calculation with isodensity cavity, the manual says "perform a standard Cosmo calculation, add the isodensity options afterwards, and start the calculation
a second time". That's what I tried to do, I added $cosmo_isodens in the control file after running a cosmo calculation with standard cavity radius but the ridft output says(after printing the atomic coordinates and basis sets)-

"MODTRACE: no modules on stack

 ERROR: isodensity COSMO not impl. for parallel calculations
 ridft ended abnormally"


 Even if I run the calculation on one node, it says exactly the same thing. I'm adding my control file in case anyone wants to have a look at it. Can someone shed some some light? Thanks a lot!

$cosmo
  rsolv= 1.30
$cosmo_atoms
# radii in Angstrom units
c  52                                                                          \
   radius=  2.0000
ru 1-51                                                                        \
   radius=  2.2230
$cosmo_isodens
$cosmo_out file=out.ccf
$title
$operating system unix
$symmetry c1
$coord    file=coord
$user-defined bonds    file=coord
$atoms
ru 1-51                                                                        \
   basis =ru ecp-28-mwb-TZVP                                                   \
   ecp   =ru ecp-28-mwb                                                        \
   jbas  =ru ecp-28-mwb-TZVP
c  52                                                                          \
   basis =c TZVP                                                               \
   jbas  =c TZVP
$basis    file=basis
$ecp    file=basis
$rundimensions
   dim(fock,dens)=1368156
   natoms=52
   nshell=570
   nbf(CAO)=1652
   nbf(AO)=1498
   dim(trafo[SAO<-->AO/CAO])=1960
   rhfshells=2
$uhfmo_alpha    file=alpha
$uhfmo_beta    file=beta
$uhf
$alpha shells
 a       1-424                                  ( 1 )
$beta shells
 a       1-398                                  ( 1 )
$scfiterlimit       6000
$thize     0.10000000E-04
$thime        5
$scfintunit
 unit=30       size=0        file=twoint
$scfdiis
$drvopt
   cartesian  on
   basis      off
   global     off
   hessian    on
   dipole     on
   nuclear polarizability
$interconversion  off
   qconv=1.d-7
   maxiter=25
$optimize
   internal   off
   cartesian  on
   global     off
   basis      off   logarithm
$coordinateupdate
   dqmax=0.3
   interpolate  on
   statistics    5
$forceupdate
   ahlrichs numgeo=0  mingeo=3 maxgeo=4 modus=<g|dq> dynamic fail=0.3
   threig=0.005  reseig=0.005  thrbig=3.0  scale=1.00  damping=0.0
$forceinit on
   diag=default
$energy    file=energy
$grad    file=gradient
$forceapprox    file=forceapprox
$lock off
$dft
   functional b-p
   gridsize   m4
$scfconv   7
$scfdamp   start=0.700  step=0.050  min=0.050
$scforbitalshift  closedshell=0.3  automatic! 0.3
$ricore      500
$rij
$jbas    file=auxbasis
$actual step      ridft
$last SCF energy change = -4885.9766
$charge from ridft
          0.000 (not to be modified here)
$dipole from ridft
  x     1.01636162089926    y     1.02978983035428    z    -0.92401865887405    a.u.
   | dipole | =    4.3636043312  debye
$orbital_max_rnorm 0.30048930118143E-03
$end

uwe

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 410
  • Karma: +0/-0
Re: COSMO isodensity cavity
« Reply #1 on: November 05, 2015, 03:37:09 pm »
Hello,

the isodensity cavity is not parallelized, as given in the error output. Please use the serial version of Turbomole instead:

unset PARA_ARCH
source $TURBODIR/Config_turbo_env
ridft &> ridft.out



Regards,

Uwe

saleheen_noman

  • Jr. Member
  • **
  • Posts: 10
  • Karma: +0/-0
Re: COSMO isodensity cavity
« Reply #2 on: November 10, 2015, 10:24:48 pm »
Hi Uwe

Thank you so much! Sorry for posting this late but I was badly sick the last few days. I'm still having some problem running this calculation. Now it says I have illegal combination of keywords. I tried all sorts of variations but failed. The manual says,
"If the $cosmo isodens keyword is given without suboptions, a scaled iosodensity cavity with default settings will be created". So after defining $cosmo_atoms, I added $cosmo_isodens but it doesn't work. I tried including the sub options dx=0.3 and all_dens= 0.0016, the isodensity value of carbon; but the program says

MODTRACE: no modules on stack

 ERROR: illegal keyword combination: $cosmo_isorad + all_dens
.

Obviously I'm using wrong keyword combinations. This is what my cosmo part of control looks like-

$cosmo
  rsolv= 1.30
$cosmo_atoms
# radii in Angstrom units
c  52                                                                          \
   radius=  2.0000
ru 1-51                                                                        \
   radius=  2.2230
$cosmo_isodens
   dx= 0.3
   all_dens= 0.0016
$cosmo_out file=out.ccf

I also tried commenting out the radius of cosmo atoms and rsolv, but it doesn't work. Could you help me out? Again, thanks a lot for your time.

Saleheen

uwe

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 410
  • Karma: +0/-0
Re: COSMO isodensity cavity
« Reply #3 on: November 11, 2015, 11:57:23 am »
Hello,

is that Turbomole version 6.x ? There was a bug in the routine that checked the keywords - it does not allow to use the combination of isodens and all_dens options.

You could write the density values to the $TURBODIR/parameter/radii.cosmo file (replace the -1 at Ru by 0.0016) and remove the all_dens keyword.

Or, alternatively, use Turbomole version 7.x which has this bug fixed.

By the way: If you use the isodensity based cavity you do not need the $cosmo_atoms keyword.

Regards,

Uwe

saleheen_noman

  • Jr. Member
  • **
  • Posts: 10
  • Karma: +0/-0
Re: COSMO isodensity cavity
« Reply #4 on: November 11, 2015, 09:58:59 pm »
Hi Uwe

Thank you so much! It solved the problem. Yes, I've been using 6.x version.

Thanks!
Saleheen

saleheen_noman

  • Jr. Member
  • **
  • Posts: 10
  • Karma: +0/-0
Re: COSMO isodensity cavity
« Reply #5 on: November 13, 2015, 07:58:14 pm »
Hi Uwe

I have one last question. Since we don't have any optimized isodensity values for many elements in radii.cosmo file, is there a meaningful approach to select isodensity values for transition metals?

Thanks you so much!
Saleheen

uwe

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 410
  • Karma: +0/-0
Re: COSMO isodensity cavity
« Reply #6 on: November 16, 2015, 04:47:54 pm »
Hello,

no, there is no black-box approach to select isodensity values. The optimized ones in the radii.cosmo file are from COSMO-RS calculations which have been fitted to experimental data. For transition metals there are not many reliable data points to fit the radii to.

I'd simply use a value for all transition metals (something between 0.001 and 0.003 as a starting point) and try to find a value which matches your needs. Once found, it is important to stick to this value in order to be able to compare total energies.

Instead of using all_dens it might be better to change the radii.cosmo file for each element individually.

Regards,

Uwe

saleheen_noman

  • Jr. Member
  • **
  • Posts: 10
  • Karma: +0/-0
Re: COSMO isodensity cavity
« Reply #7 on: November 18, 2015, 01:40:18 am »
That helps a lot. Thank you so much!

Saleheen